Você não está conectado. Conecte-se ou registre-se

Problema Animation (Mozilla)

Ver o tópico anterior Ver o tópico seguinte Ir em baixo  Mensagem [Página 1 de 1]

1Alert Problema Animation (Mozilla) em Ter Set 01, 2015 11:17 am

Eddye

avatar
Membro ativo


  • Descrição:

Meu problema é simples, eu apliquei uma animação nas ranks do fórum... até ai tudo bem, mostrei para uns amigos meus todos tinham o Chrome, e deu tudo certo. Porém 1 amigo meu relatou que no Mozilla Firefox dele o efeito da animação não pegou. Gostaria de saber como eu conseguiria resolver isso... Já tentei por: -moz-animation, animation, animation-name. Nenhuma dessas eu consegui resolver.

Se puderem me ajudar, ficarei grato.

Linha que alterei:

Código:
.userADM:before { content: "\f013";font-family: 'FontAwesome'; padding: 0 4px; -webkit-animation: spin 1.5s linear infinite; animation: 1.5s linear 0s normal none infinite running spin; }

  • Informações:



Fórum:http://www.rlplay.forumbrasil.net/Versão:PUNBB

Ver perfil do usuário

2Alert Re: Problema Animation (Mozilla) em Ter Set 01, 2015 2:16 pm

Akira

avatar
Membro ativo

Olá, substitua seu código por este:

Código:
.userADM:before { content: "\f013";font-family: 'FontAwesome'; padding: 0 4px; -webkit-animation: spin 1.5s linear infinite; animation: 1.5s linear 0s normal none infinite running spin; -moz-animation: spin 1.5s linear infinite; }


Resolveu?


@Edit: Para uma classe animation funcionar no Mozilla basta adicionar o prefixo "-moz-".
Exemplo:
"-moz-animation: all 1.5s;"

:3



Olá Convidado, seja bem vindo a Best Skins, seu fórum de skins e suporte.
Sempre leia as regras do fórum.
Suporte e skins para seu fórum!


Ver perfil do usuário

3Alert Re: Problema Animation (Mozilla) em Ter Set 01, 2015 2:41 pm

Eddye

avatar
Membro ativo

Como havia falado antes... eu coloquei o "-moz-" e não resultou. Eu testei o código que me passou pra ver se não era alguma organização. Também não resultou... aguardo novas respostas :/

Ver perfil do usuário

4Alert Re: Problema Animation (Mozilla) em Ter Set 01, 2015 6:30 pm

Cepheus

avatar
Admin

Basta apenas adicionar isso no seu elemento:

Código:
 display: inline-block;

Ele ficará assim:
Código:
.userADM:before { content: "\f013";font-family: 'FontAwesome'; padding: 0 4px; -webkit-animation: spin 1.5s linear infinite; animation: 1.5s linear 0s normal none infinite running spin; display: inline-block;}





  • Gostou?
     não esqueça de
  • Reputar!



    Ver perfil do usuário

    5Alert Re: Problema Animation (Mozilla) em Ter Set 01, 2015 7:39 pm

    Eddye

    avatar
    Membro ativo

    Tópico resolvido, valeu Cepheus. Pode fechar.

    Ver perfil do usuário

    6Alert Re: Problema Animation (Mozilla) em Ter Set 01, 2015 8:18 pm

    Cepheus

    avatar
    Admin

    [alerta="Mensagem automática"][/alerta]



    Este tópico foi movido de "CSS" para "Arquivos".





  • Gostou?
     não esqueça de
  • Reputar!



    Ver perfil do usuário

    Conteúdo patrocinado


    Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo  Mensagem [Página 1 de 1]

    Permissão deste fórum:
    Você não pode responder aos tópicos neste fórum